System Requirements for AWS Advanced Templates

System Requirements for AWS Advanced Templates

Hardware

An Amazon EC2 m3.xlarge instance. Selecting smaller-sized VMs is not recommended, and selecting fewer VMs will likely cause certain resource-intensive services, such as distributed datastores, to not work properly.

Software

  • The DC/OS advanced AWS templates.
  • An Amazon Web Services account with root IAM privileges. Advanced privileges are required to install the advanced templates. Contact your AWS admin for more information.
  • An Amazon EC2 Key Pair for the same region as your cluster. Key pairs cannot be shared across regions. The AWS key pair uses public-key cryptography to provide secure login to your AWS cluster. For more information about creating an Amazon EC2 Key Pair, see the documentation.
  • AWS Command Line Interface
  • The CLI JSON processor jq